firebase_core 0.4.2+2

  • Readme
  • Changelog
  • Example
  • Installing
  • 100

Firebase Core for Flutter #

pub package

Flutter插件可使用Firebase Core API,从而可以连接到多个Firebase应用程序.

有关其他Firebase产品的Flutter插件,请参阅README.md .

Usage #

要使用此插件,添加firebase_core您pubspec.yaml文件相关 .

Getting Started #

有关使用Firebase Core的完整示例应用程序,请参见example目录.

Issues and feedback #

请在我们的问题跟踪器中提交Flutterfire特定的问题,错误或功能请求.

并非Flutterfire特有的插件问题可以在Flutter问题跟踪器中提出 .

要对此插件做出更改,请查看我们的贡献指南 ,并发送请求请求 .

0.4.2+2 #

  • Remove the deprecated author: field from pubspec.yaml
  • 将插件迁移到pubspec平台清单.
  • 将Flutter的最低版本提高到1.10.0.

0.4.2+1 #

  • 在检查Platform.isIos以获取默认应用程序名称之前,请先检查kIsWeb .

0.4.2 #

  • 迁移到firebase_core_platform_interface .

0.4.1+6 #

  • 包结构已更改,请立即更新主页.

0.4.1+5 #

0.4.1+4 #

  • 从FirebaseApp构造函数中删除visibleForTesting批注.

0.4.1+3 #

  • 更新了README说明,以与其他Flutterfire插件保持一致.

0.4.1+2 #

  • 删除AndroidX警告.

0.4.1+1 #

  • 将生命周期依赖项包含为Android上的compileOnly,以解决与其他传递库的潜在版本冲突.

0.4.1 #

  • 支持Android v2嵌入.

0.4.0+9 #

  • 更新文档以反映新的存储库位置.
  • 更新单元测试以调用TestWidgetsFlutterBinding.ensureInitialized .

0.4.0+8 #

  • 在文档和示例中将google-services Android gradle插件更新为4.3.0.

0.4.0+7 #

  • 修复Android编译警告.

0.4.0+6 #

  • 向Firebase报告使用情况时,自动使用pubspec.yaml中的版本.

0.4.0+5 #

  • 自动插件版本检索的回滚.

0.4.0+4 #

  • 向Firebase报告使用情况时,自动检索插件的版本.

0.4.0+3 #

  • 将缺少的模板类型参数添加到invokeMethod调用中.
  • 将Flutter的最低版本提高到1.5.0.
  • 必要时,将invokeMethod替换为invokeMapMethod.

0.4.0+2 #

  • 更新用户代理名称. 设置为flutter-fire-core以与其他库保持一致.

0.4.0+1 #

  • 将用户代理发送到Firebase.

0.4.0 #

  • 将Android依赖项更新为最新版本.

0.3.4 #

  • 将Android firebase-core依赖性更新为与其他Flutterfire插件兼容的版本.

0.3.3 #

  • 删除Gradle BoM以避免Gradle版本问题.

0.3.2 #

  • 将Android依赖项移至Gradle BoM,以帮助维持与其他FlutterFire插件的兼容性.

0.3.1+1 #

  • 在静态函数上添加nil检查,以防止崩溃或不良行为.

0.3.1 #

  • 删除可能干扰热重启的断言.

0.3.0+2 #

  • 删除类别.

0.3.0+1 #

  • 在构建时记录有关先前AndroidX迁移的更详细的警告.

0.3.0 #

  • 突破性的改变 . 从已弃用的原始Android支持库迁移到AndroidX. 这不应该导致任何功能上的变化,但是如果使用原始插件的Android应用程序也必须迁移 ,因此它们也必须进行迁移 .

0.2.5+1 #

  • 将Android依赖项更新到最新版本.

0.2.5 #

  • 碰撞Android和Firebase依赖版本.

0.2.4 #

  • 更新了Gradle工具以匹配Android Studio 3.1.2.

0.2.3 #

  • Google Play服务依赖项已更新至版本15.0.0.

0.2.2 #

  • Cocoapods 1.5.0的简化podspec,避免了应用档案中的链接问题.

0.2.1 #

  • 修复了在Android上设置项目ID的问题.

0.2.0 #

  • 突破性的改变 . 现在,Options API是异步的,可以与配置Firebase应用程序的本机代码互操作.
  • 为默认应用提供吸气剂
  • 修复iOS上GCM发送者ID的设置

0.1.2 #

  • 在iOS上修复projectID

0.1.1 #

  • 修复命名Firebase应用程序的构造函数的行为.

0.1.0 #

  • 突破性的改变 . 设置SDK约束以匹配Flutter beta版本.

0.0.7 #

  • 修复了Dart 2类型错误.

0.0.6 #

  • 已在Swift项目中启用.

0.0.5 #

  • 已移至io.flutter.plugins组织.

0.0.4 #

  • 修复了来自Dart 2.0分析仪的警告.
  • 将Android项目模板简化并升级到Android SDK 27.
  • 更新了软件包说明.

0.0.3 #

  • 突破性的改变 . 升级到Gradle 4.1和Android Studio Gradle插件3.0.1. 较早的Flutter项目也需要升级其Gradle设置才能使用此版本的插件. 说明可以在这里找到.

0.0.2 #

  • 修复了Android上的数据库URL
  • 在Android上将GCM发送者ID设置为可选
  • 将GMS依赖关系放宽到11. +

0.0.1 #

  • 初始发行

example/README.md

firebase_core_example #

演示如何使用firebase_core插件.

Getting Started #

要获得Flutter入门方面的帮助,请查看我们的在线文档 .

Use this package as a library

1. Depend on it

将此添加到包的pubspec.yaml文件中:


dependencies:
  firebase_core: ^0.4.2+2

2. Install it

您可以从命令行安装软件包:

使用Flutter:


$ flutter pub get

另外,您的编辑器可能支持flutter pub get . 查看您的编辑器文档以了解更多信息.

3. Import it

现在,在Dart代码中,您可以使用:


import 'package:firebase_core/firebase_core.dart';
  
Popularity:
描述该程序包相对于其他程序包的受欢迎程度. [更多]
100
Health:
从静态分析得出的代码运行状况. [更多]
100
Maintenance:
反映出软件包的整洁和最新状态. [更多]
100
Overall:
以上的加权分数. [更多]
100
了解有关得分的更多信息.

我们在2019年12月11日分析了此软件包,并在下面提供了分数,详细信息和建议. using: 分析已完成,状态使用以下命令 :

  • 飞镖:2.7.0
  • 最高:0.13.1 + 4
  • Flutter:1.12.13 + hotfix.4

Dependencies

Package Constraint Resolved Available
直接依赖
Dart SDK > = 2.0.0-dev.28.0 <3.0.0
firebase_core_platform_interface ^1.0.0 1.0.2
flutter 0.0.0
meta ^1.0.5 1.1.8
传递依存关系
collection 1.14.11 1.14.12
matcher 0.12.6
path 1.6.4
quiver 2.1.2+1
sky_engine 0.0.99
stack_trace 1.9.3
typed_data 1.1.6
vector_math 2.0.8
开发依赖
e2e ^0.2.1
flutter_driver
flutter_test
mockito ^4.1.1

by  ICOPY.SITE