shared_preferences 0.5.8

Flutter Android iOS web

Flutter插件,用于读写简单的键值对. 在iOS上包装NSUserDefaults,在Android上包装SharedPreferences.

1292
likes
110 / 110
酒馆积分
100 %
popularity

我们在2020年8月3日对该计划进行了分析,并向其授予了110个酒吧积分(可能获得110个积分):

遵循Dart文件约定
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

提供文件
20 / 20

10/10 points: Package has an example

  • 在以下位置找到示例: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 21个API元素中有20个(95.2%)具有文档注释.
支持多种平台
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

考虑支持以下预发行平台:

软件包不支持Flutter平台Windows

Because:

  • package:shared_preferences/shared_preferences.dart声明支持以下平台:Android,iOS,Linux,macOS,Web

这些问题存在,但不会影响得分,因为它们可能不是您的包裹中产生的:

套餐不支持Flutter平台的Android

Because:

  • package:shared_preferences/shared_preferences.dart导入:
  • 声明对平台的支持的package:shared_preferences_linux/shared_preferences_linux.dart :Linux
软件包不支持Flutter平台iOS

Because:

  • package:shared_preferences/shared_preferences.dart导入:
  • 声明对平台的支持的package:shared_preferences_linux/shared_preferences_linux.dart :Linux
软件包不支持Flutter平台macOS

Because:

  • package:shared_preferences/shared_preferences.dart导入:
  • 声明对平台的支持的package:shared_preferences_linux/shared_preferences_linux.dart :Linux
软件包不支持Flutter平台Web

Because:

  • package:shared_preferences/shared_preferences.dart导入:
  • 声明对平台的支持的package:shared_preferences_linux/shared_preferences_linux.dart :Linux
通过静态分析
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

支持最新的依赖
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
meta^1.0.41.1.81.2.2
shared_preferences_linux^0.0.20.0.2+10.0.2+1
shared_preferences_macos^0.0.10.0.1+100.0.1+10
shared_preferences_platform_interface^1.0.01.0.41.0.4
shared_preferences_web^0.1.20.1.2+70.1.2+7
传递依存关系
PackageConstraintCompatibleLatest
collection-1.14.121.14.13
file-5.2.15.2.1
flutter_web_plugins-0.0.00.0.0
intl-0.16.10.16.1
path-1.7.01.7.0
path_provider_linux-0.0.1+20.0.1+2
path_provider_platform_interface-1.0.21.0.2
platform-2.2.12.2.1
plugin_platform_interface-1.0.21.0.2
process-3.0.133.0.13
sky_engine-0.0.990.0.99
typed_data-1.1.61.2.0
vector_math-2.0.82.0.8
xdg_directories-0.1.00.1.0

要重现运行pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides .

10/10 points: Package supports latest stable Dart and Flutter SDKs

1292
likes
110
pub points
100%
popularity

Publisher

flutter.dev

Flutter插件,用于读写简单的键值对. 在iOS上包装NSUserDefaults,在Android上包装SharedPreferences.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD( 许可

Dependencies

flutter, meta, shared_preferences_linux, shared_preferences_macos, shared_preferences_platform_interface, shared_preferences_web

More

Packages that depend on shared_preferences

by  ICOPY.SITE